Existing client ticket issues
Incident Report for Magic Internet Group Limited
Postmortem

What was the issue?

Customers who use an email account managed within their cPanel were unable to email any @magicwebdesigns.co.uk or @magicinternetgroup.com email. This meant that customers who had received an email from us, for example a reply to a ticket they created, they were unable to reply to it. Customers would get an error saying “No such user”.

What caused this issue?

We manage our DNS via our provider, Cloudflare and we use Google (G Suite) for our emails. Whilst we had our emails configured correctly, there was two DNS records which meant users on the same server as our domain would be ‘linked together’ and would bypass our external email system (G Suite). This therefore meant that because the email accounts did not exist in our server users were getting an error.

How we fixed it

As a permanent fix, we changed the DNS records immediately, but for some people this won't take effect for up to 48 hours, so we also created the mailboxes affected on our server and set up a forwarding rule to forward it onto the correct email address to ensure it is processed via our ticketing system.

Has it been fully resolved?

Yep! As soon as we created that email box things started to work again. And with the DNS being updated, this won't happen again.

What percentage of users were affected?

Records show that 15% of tickets created in the last 30 days were created by an email managed by us.

Posted May 23, 2020 - 20:41 BST

Resolved
We have implemented a fix and the issue has now been resolved.
Posted May 18, 2020 - 15:11 BST
Identified
We have identified the issue and our engineers are now working on a fix.
Posted May 18, 2020 - 15:06 BST
Investigating
[This issue affects customers who are using an email on their cPanel account]
If a customer tries to reply to a ticket via an email within their cPanel account they will get a mail delivery error. We are looking into this.

As a workaround, customers can view the request by clicking 'View request' on the email they are trying to reply to.
Posted May 18, 2020 - 14:38 BST
This incident affected: Customer Service (Email/Ticket).