Disruption in several Control Panel areas
Incident Report for Magic Internet Group Limited
Resolved
This incident has been resolved.
Posted Jul 04, 2020 - 13:49 BST
Investigating
Some customers may be unable to access their domain and SSL control centre.
Posted Jul 04, 2020 - 10:51 BST
This incident affected: Customer Portal (Customer Website).